import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<img[^>]+src=(\\\"|')([^\\\"']+)(\\\"|')[^>]*>";
final String string = "<h1>My main item</h1>\n"
+ "<img src=\"http://www.blah.com/My First Image Here.jpg\">\n"
+ "<h2>Some extra data</h2>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}