re = /<img[^>]+src=(\"|')([^\"']+)(\"|')[^>]*>/i
str = '<h1>My main item</h1>
<img src="http://www.blah.com/My First Image Here.jpg">
<h2>Some extra data</h2>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end