#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "tel:(\+\d{1,20})"
Local $sString = "P-Asserted-Identity: "Cullen Jennings" <sip:fluffy@cisco.com>" & @CRLF & _
"P-Asserted-Identity: tel:+14085264000" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")