package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`tel:(\+\d{1,20})`)
var str = `P-Asserted-Identity: "Cullen Jennings" <sip:fluffy@cisco.com>
P-Asserted-Identity: tel:+14085264000
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}