import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "tel:(\\+\\d{1,20})";
final String string = "P-Asserted-Identity: \"Cullen Jennings\" <sip:fluffy@cisco.com>\n"
+ "P-Asserted-Identity: tel:+14085264000\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}