using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Nissan(?!((?!<\/a>).)*<\/a>|((?!<\/span>).)*<\/span>)";
string input = @"Nissan
nissan
<span>Nissan</span>
<a href=""nissan.com"">Nissan</a>
<a href=""nissan.com""><span>Nissan</span></a>
Company Nissan is a name. and Nissan Micra is model name.
Company <a href=""nissan.com""><span>Nissan</span></a> is a name. and Nissan Micra is model name.
This is new <a href='https://www.url.com'><span>URL</span></a>.<br /> Company Nissan is a name. and Nissan Micra is model name. </p>
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}