import re
regex = re.compile(r"Nissan(?!((?!<\/a>).)*<\/a>|((?!<\/span>).)*<\/span>)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("Nissan\n"
"nissan\n"
"<span>Nissan</span>\n"
"<a href=\"nissan.com\">Nissan</a>\n"
"<a href=\"nissan.com\"><span>Nissan</span></a>\n"
"Company Nissan is a name. and Nissan Micra is model name. \n"
"Company <a href=\"nissan.com\"><span>Nissan</span></a> is a name. and Nissan Micra is model name. \n"
"This is new <a href='https://www.url.com'><span>URL</span></a>.<br /> Company Nissan is a name. and Nissan Micra is model name. </p>\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")