re = /Nissan(?!((?!<\/a>).)*<\/a>|((?!<\/span>).)*<\/span>)/mi
str = 'Nissan
nissan
<span>Nissan</span>
<a href="nissan.com">Nissan</a>
<a href="nissan.com"><span>Nissan</span></a>
Company Nissan is a name. and Nissan Micra is model name.
Company <a href="nissan.com"><span>Nissan</span></a> is a name. and Nissan Micra is model name.
This is new <a href=\'https://www.url.com\'><span>URL</span></a>.<br /> Company Nissan is a name. and Nissan Micra is model name. </p>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end