const regex = new RegExp('Nissan(?!((?!<\\/a>).)*<\\/a>|((?!<\\/span>).)*<\\/span>)', 'mig')
const str = `Nissan
nissan
<span>Nissan</span>
<a href="nissan.com">Nissan</a>
<a href="nissan.com"><span>Nissan</span></a>
Company Nissan is a name. and Nissan Micra is model name.
Company <a href="nissan.com"><span>Nissan</span></a> is a name. and Nissan Micra is model name.
This is new <a href='https://www.url.com'><span>URL</span></a>.<br /> Company Nissan is a name. and Nissan Micra is model name. </p>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}