#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((http:\/\/sim\d{1,5}.agni.lindenlab.com:\d{4,5})(\/cap\/\w{8}-\w{4}-\w{4}-\w{4}-\w{12}))"
Local $sString = "http://sim99991.agni.lindenlab.com:12046/cap/171ef743-106d-6a5f-119f-3fe098038d3d"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")