use strict;
my $str = 'http://sim99991.agni.lindenlab.com:12046/cap/171ef743-106d-6a5f-119f-3fe098038d3d';
my $regex = qr/((http:\/\/sim\d{1,5}.agni.lindenlab.com:\d{4,5})(\/cap\/\w{8}-\w{4}-\w{4}-\w{4}-\w{12}))/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}