re = /((http:\/\/sim\d{1,5}.agni.lindenlab.com:\d{4,5})(\/cap\/\w{8}-\w{4}-\w{4}-\w{4}-\w{12}))/
str = 'http://sim99991.agni.lindenlab.com:12046/cap/171ef743-106d-6a5f-119f-3fe098038d3d'
# Print the match result
str.match(re) do |match|
puts match.to_s
end