const regex = /((http:\/\/sim\d{1,5}.agni.lindenlab.com:\d{4,5})(\/cap\/\w{8}-\w{4}-\w{4}-\w{4}-\w{12}))/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((http:\\\/\\\/sim\\d{1,5}.agni.lindenlab.com:\\d{4,5})(\\\/cap\\\/\\w{8}-\\w{4}-\\w{4}-\\w{4}-\\w{12}))', '')
const str = `http://sim99991.agni.lindenlab.com:12046/cap/171ef743-106d-6a5f-119f-3fe098038d3d`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}