// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"((http:\/\/sim\d{1,5}.agni.lindenlab.com:\d{4,5})(\/cap\/\w{8}-\w{4}-\w{4}-\w{4}-\w{12}))").unwrap();
let string = "http://sim99991.agni.lindenlab.com:12046/cap/171ef743-106d-6a5f-119f-3fe098038d3d";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}