const regex = new RegExp('/(?<resource>[\\w\\-]+)(?:/(?<id>(?!actions)[\\w\\-]+))?(?:/actions/(?<action>[\\w\\-]+))?', 'gm')
const str = `/resource
/resource/1
/resource/1/sub-resource
/resource/1/sub-resource/2
/resource/1/sub-resource/2/sub-sub-resource
/resource/1/sub-resource/2/sub-sub-resource/3
/resource/actions/complete
/resource/1/actions/complete
/resource/1/sub-resource/actions/complete
/resource/1/sub-resource/2/actions/complete
/resource/1/sub-resource/2/sub-sub-resource/actions/complete
/resource/1/sub-resource/2/sub-sub-resource/3/actions/complete`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}