import Foundation
let pattern = #"/(?<resource>[\w\-]+)(?:/(?<id>(?!actions)[\w\-]+))?(?:/actions/(?<action>[\w\-]+))?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/resource
/resource/1
/resource/1/sub-resource
/resource/1/sub-resource/2
/resource/1/sub-resource/2/sub-sub-resource
/resource/1/sub-resource/2/sub-sub-resource/3
/resource/actions/complete
/resource/1/actions/complete
/resource/1/sub-resource/actions/complete
/resource/1/sub-resource/2/actions/complete
/resource/1/sub-resource/2/sub-sub-resource/actions/complete
/resource/1/sub-resource/2/sub-sub-resource/3/actions/complete
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)