#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)length ?= ?\"[\+\-]?\d+(?:\.\d+)?\".*height ?= ?\"[\+\-]?\d+(?:\.\d+)?\""
Local $sString = "<house prize="2000000"" & @CRLF & _
" length="-1200"" & @CRLF & _
" owner="Smith"" & @CRLF & _
" height="55.8"/>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")