package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)length ?= ?\"[\+\-]?\d+(?:\.\d+)?\".*height ?= ?\"[\+\-]?\d+(?:\.\d+)?\"`)
var str = `<house prize="2000000"
length="-1200"
owner="Smith"
height="55.8"/>
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}