using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"length ?= ?\""[\+\-]?\d+(?:\.\d+)?\"".*height ?= ?\""[\+\-]?\d+(?:\.\d+)?\""";
string input = @"<house prize=""2000000""
length=""-1200""
owner=""Smith""
height=""55.8""/>
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}