re = /length ?= ?\"[\+\-]?\d+(?:\.\d+)?\".*height ?= ?\"[\+\-]?\d+(?:\.\d+)?\"/m
str = '<house prize="2000000"
length="-1200"
owner="Smith"
height="55.8"/>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end