using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^if\s*\(([^)(]+(?:\([^)(]*\)[^)(]*)*)\)\s((?:(?!else|endif).)+)(?:\selse\s((?:(?!endif).)+))?\sendif$";
string input = @"if(s) what; else asd endif
if(stat(life) >= 2) deal_damage(5) else gain_block(5) endif
if (whatever i want) deal_damage(1) endif
if( has_status_fx(chill) ) gain_block(1) endif
if(true) deal_damage(5) (no endif)
if (false)gain_block(1) endif (first parenthesis doesnt have a space after)
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}