# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^if\s*\(([^)(]+(?:\([^)(]*\)[^)(]*)*)\)\s((?:(?!else|endif).)+)(?:\selse\s((?:(?!endif).)+))?\sendif$"
test_str = ("if(s) what; else asd endif\n\n"
"if(stat(life) >= 2) deal_damage(5) else gain_block(5) endif\n"
"if (whatever i want) deal_damage(1) endif\n"
"if( has_status_fx(chill) ) gain_block(1) endif\n\n"
"if(true) deal_damage(5) (no endif)\n"
"if (false)gain_block(1) endif (first parenthesis doesnt have a space after)\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.