const regex = /^if\s*\(([^)(]+(?:\([^)(]*\)[^)(]*)*)\)\s((?:(?!else|endif).)+)(?:\selse\s((?:(?!endif).)+))?\sendif$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^if\\s*\\(([^)(]+(?:\\([^)(]*\\)[^)(]*)*)\\)\\s((?:(?!else|endif).)+)(?:\\selse\\s((?:(?!endif).)+))?\\sendif$', 'gm')
const str = `if(s) what; else asd endif
if(stat(life) >= 2) deal_damage(5) else gain_block(5) endif
if (whatever i want) deal_damage(1) endif
if( has_status_fx(chill) ) gain_block(1) endif
if(true) deal_damage(5) (no endif)
if (false)gain_block(1) endif (first parenthesis doesnt have a space after)
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}