$re = '/^if\s*\(([^)(]+(?:\([^)(]*\)[^)(]*)*)\)\s((?:(?!else|endif).)+)(?:\selse\s((?:(?!endif).)+))?\sendif$/m';
$str = 'if(s) what; else asd endif
if(stat(life) >= 2) deal_damage(5) else gain_block(5) endif
if (whatever i want) deal_damage(1) endif
if( has_status_fx(chill) ) gain_block(1) endif
if(true) deal_damage(5) (no endif)
if (false)gain_block(1) endif (first parenthesis doesnt have a space after)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);