import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\r?\\n|\\r){2,}(?!#Example-\\d)";
final String string = "#Example-1#\n"
+ "The correct answer is (B) 2 to 3. jfbgfdgdf sgdsgsd.\n\n"
+ "jfbgfdgdf sgdsgsd.\n"
+ "#End Example-1#\n\n"
+ "#Example-2#\n"
+ "The correct answer is (B) 2 to 3. jfbgfdgdf sgdsgsd.\n"
+ "jfbgfdgdf sgdsgsd.\n"
+ "#End Example-2#";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}