import re
regex = re.compile(r"(\r?\n|\r){2,}(?!#Example-\d)")
test_str = ("#Example-1#\n"
"The correct answer is (B) 2 to 3. jfbgfdgdf sgdsgsd.\n\n"
"jfbgfdgdf sgdsgsd.\n"
"#End Example-1#\n\n"
"#Example-2#\n"
"The correct answer is (B) 2 to 3. jfbgfdgdf sgdsgsd.\n"
"jfbgfdgdf sgdsgsd.\n"
"#End Example-2#")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)