const regex = /(\r?\n|\r){2,}(?!#Example-\d)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\r?\\n|\\r){2,}(?!#Example-\\d)', 'g')
const str = `#Example-1#
The correct answer is (B) 2 to 3. jfbgfdgdf sgdsgsd.
jfbgfdgdf sgdsgsd.
#End Example-1#
#Example-2#
The correct answer is (B) 2 to 3. jfbgfdgdf sgdsgsd.
jfbgfdgdf sgdsgsd.
#End Example-2#`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);