use strict;
my $str = '#!/usr/bin/env dub
/**
* Copyright (C) blah blah blah
* Some long copyright notice
* Some long copyright notice
* Some long copyright notice
* Some long copyright notice
* Some long copyright notice
* Some long copyright notice
* Some long copyright notice
* Some long copyright notice
*/
/+
// Example and/or documentation on changing this program
Some codeSome codeSome codeSome code
Some codeSome codeSome codeSome code
/*
* Note that when doing the below !not threadsafe!...
* see next example for threadsafe version.
*/
Some codeSome codeSome codeSome code
Some codeSome codeSome codeSome code
Some codeSome codeSome codeSome code
Some codeSome codeSome codeSome code
/*
* This is the threadsafe version of above both are provided.
* threadsafe version is not quite as fast
*/
Some codeSome codeSome codeSome code
Some codeSome codeSome codeSome code // this line has to be here
Some codeSome codeSome codeSome code
+/
/+ dub.sdl:
name "colortest"
dependency "color" version="~>0.0.3"
+/
// implementation of support functions
void main(string[] args) {
...
}
';
my $regex = qr/\n\/\+\s*dub\.(sdl|json):?\n(.*)\n\+\/\n/sp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}