// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)\n\/\+\s*dub\.(sdl|json):?\n(.*)\n\+\/\n").unwrap();
let string = "#!/usr/bin/env dub
/**
* Copyright (C) blah blah blah
* Some long copyright notice
* Some long copyright notice
* Some long copyright notice
* Some long copyright notice
* Some long copyright notice
* Some long copyright notice
* Some long copyright notice
* Some long copyright notice
*/
/+
// Example and/or documentation on changing this program
Some codeSome codeSome codeSome code
Some codeSome codeSome codeSome code
/*
* Note that when doing the below !not threadsafe!...
* see next example for threadsafe version.
*/
Some codeSome codeSome codeSome code
Some codeSome codeSome codeSome code
Some codeSome codeSome codeSome code
Some codeSome codeSome codeSome code
/*
* This is the threadsafe version of above both are provided.
* threadsafe version is not quite as fast
*/
Some codeSome codeSome codeSome code
Some codeSome codeSome codeSome code // this line has to be here
Some codeSome codeSome codeSome code
+/
/+ dub.sdl:
name \"colortest\"
dependency \"color\" version=\"~>0.0.3\"
+/
// implementation of support functions
void main(string[] args) {
...
}
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}