$re = '/\n\/\+\s*dub\.(sdl|json):?\n(.*)\n\+\/\n/s';
$str = '#!/usr/bin/env dub
/**
* Copyright (C) blah blah blah
* Some long copyright notice
* Some long copyright notice
* Some long copyright notice
* Some long copyright notice
* Some long copyright notice
* Some long copyright notice
* Some long copyright notice
* Some long copyright notice
*/
/+
// Example and/or documentation on changing this program
Some codeSome codeSome codeSome code
Some codeSome codeSome codeSome code
/*
* Note that when doing the below !not threadsafe!...
* see next example for threadsafe version.
*/
Some codeSome codeSome codeSome code
Some codeSome codeSome codeSome code
Some codeSome codeSome codeSome code
Some codeSome codeSome codeSome code
/*
* This is the threadsafe version of above both are provided.
* threadsafe version is not quite as fast
*/
Some codeSome codeSome codeSome code
Some codeSome codeSome codeSome code // this line has to be here
Some codeSome codeSome codeSome code
+/
/+ dub.sdl:
name "colortest"
dependency "color" version="~>0.0.3"
+/
// implementation of support functions
void main(string[] args) {
...
}
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);