# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\n\/\+\s*dub\.(sdl|json):?\n(.*)\n\+\/\n"
test_str = ("#!/usr/bin/env dub\n"
"/**\n"
" * Copyright (C) blah blah blah\n"
" * Some long copyright notice\n"
" * Some long copyright notice\n"
" * Some long copyright notice\n"
" * Some long copyright notice\n"
" * Some long copyright notice\n"
" * Some long copyright notice\n"
" * Some long copyright notice\n"
" * Some long copyright notice\n"
"*/\n"
"/+\n"
"// Example and/or documentation on changing this program\n"
"Some codeSome codeSome codeSome code\n"
"Some codeSome codeSome codeSome code\n"
"/*\n"
" * Note that when doing the below !not threadsafe!...\n"
" * see next example for threadsafe version.\n"
" */\n"
"Some codeSome codeSome codeSome code\n"
"Some codeSome codeSome codeSome code\n"
"Some codeSome codeSome codeSome code\n"
"Some codeSome codeSome codeSome code\n"
"/*\n"
" * This is the threadsafe version of above both are provided.\n"
" * threadsafe version is not quite as fast\n"
" */\n"
"Some codeSome codeSome codeSome code\n"
"Some codeSome codeSome codeSome code // this line has to be here\n"
"Some codeSome codeSome codeSome code\n\n"
"+/\n\n"
"/+ dub.sdl:\n"
" name \"colortest\"\n"
" dependency \"color\" version=\"~>0.0.3\"\n"
"+/\n\n"
"// implementation of support functions\n\n"
"void main(string[] args) {\n"
"...\n"
"}\n\n")
matches = re.search(regex, test_str, re.DOTALL)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.