import Foundation
let pattern = #"\n\/\+\s*dub\.(sdl|json):?\n(.*)\n\+\/\n"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = ##"""
#!/usr/bin/env dub
/**
* Copyright (C) blah blah blah
* Some long copyright notice
* Some long copyright notice
* Some long copyright notice
* Some long copyright notice
* Some long copyright notice
* Some long copyright notice
* Some long copyright notice
* Some long copyright notice
*/
/+
// Example and/or documentation on changing this program
Some codeSome codeSome codeSome code
Some codeSome codeSome codeSome code
/*
* Note that when doing the below !not threadsafe!...
* see next example for threadsafe version.
*/
Some codeSome codeSome codeSome code
Some codeSome codeSome codeSome code
Some codeSome codeSome codeSome code
Some codeSome codeSome codeSome code
/*
* This is the threadsafe version of above both are provided.
* threadsafe version is not quite as fast
*/
Some codeSome codeSome codeSome code
Some codeSome codeSome codeSome code // this line has to be here
Some codeSome codeSome codeSome code
+/
/+ dub.sdl:
name "colortest"
dependency "color" version="~>0.0.3"
+/
// implementation of support functions
void main(string[] args) {
...
}
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}