package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(tasker 2\.5\.[0-9][0-2])|(tasker 2\.5\.[0-9])|(tasker 2\.[0-4]\.\d+)`)
var str = `tasker 2.5.9 tasker 2.5.11 tasker 2.3.2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}