import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(tasker 2\\.5\\.[0-9][0-2])|(tasker 2\\.5\\.[0-9])|(tasker 2\\.[0-4]\\.\\d+)";
final String string = "tasker 2.5.9 tasker 2.5.11 tasker 2.3.2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}