re = /(tasker 2\.5\.[0-9][0-2])|(tasker 2\.5\.[0-9])|(tasker 2\.[0-4]\.\d+)/
str = 'tasker 2.5.9 tasker 2.5.11 tasker 2.3.2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end