const regex = /(tasker 2\.5\.[0-9][0-2])|(tasker 2\.5\.[0-9])|(tasker 2\.[0-4]\.\d+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(tasker 2\\.5\\.[0-9][0-2])|(tasker 2\\.5\\.[0-9])|(tasker 2\\.[0-4]\\.\\d+)', 'g')
const str = `tasker 2.5.9 tasker 2.5.11 tasker 2.3.2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}