#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((?=[0-9.]+$)((25[0-5]|(2[0-4]|1[0-9])[0-9]|[1-9]?[0-9])\.){3}(25[0-5]|(2[0-4]|1[0-9])[0-9]|[1-9]?[0-9])|(?=[0-9.]*[a-zA-Z])([a-zA-Z0-9]|[a-zA-Z0-9][a-zA-Z0-9-]{0,61}[a-zA-Z0-9])((\.([a-zA-Z0-9]|[a-zA-Z0-9][a-zA-Z0-9-]{0,61}[a-zA-Z0-9]))*(\.[a-zA-Z]{2,31}))+)$"
Local $sString = "127.0.0.1" & @CRLF & _
"192.168.1.1" & @CRLF & _
"192.168.1.255" & @CRLF & _
"192.168.255.255" & @CRLF & _
"0.0.0.0" & @CRLF & _
"" & @CRLF & _
" 127.0.0.1" & @CRLF & _
"192.168.1.1a" & @CRLF & _
"192.068.1.255" & @CRLF & _
"30.168.1.255.1" & @CRLF & _
"127.1" & @CRLF & _
"192.168.1.256" & @CRLF & _
"-1.2.3.4" & @CRLF & _
"1.1.1.1." & @CRLF & _
"3...3" & @CRLF & _
"" & @CRLF & _
"toto.fr" & @CRLF & _
"truc-bidule.com" & @CRLF & _
"sub.truc-bidule.toto.com" & @CRLF & _
"" & @CRLF & _
"toto" & @CRLF & _
"toto.f" & @CRLF & _
"toto.f6" & @CRLF & _
"-3.fr" & @CRLF & _
"toto.fr " & @CRLF & _
"truc_bidule.com" & @CRLF & _
"sub..truc-bidule.toto.com" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")