# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^((?=[0-9.]+$)((25[0-5]|(2[0-4]|1[0-9])[0-9]|[1-9]?[0-9])\.){3}(25[0-5]|(2[0-4]|1[0-9])[0-9]|[1-9]?[0-9])|(?=[0-9.]*[a-zA-Z])([a-zA-Z0-9]|[a-zA-Z0-9][a-zA-Z0-9-]{0,61}[a-zA-Z0-9])((\.([a-zA-Z0-9]|[a-zA-Z0-9][a-zA-Z0-9-]{0,61}[a-zA-Z0-9]))*(\.[a-zA-Z]{2,31}))+)$"
test_str = ("127.0.0.1\n"
"192.168.1.1\n"
"192.168.1.255\n"
"192.168.255.255\n"
"0.0.0.0\n\n"
" 127.0.0.1\n"
"192.168.1.1a\n"
"192.068.1.255\n"
"30.168.1.255.1\n"
"127.1\n"
"192.168.1.256\n"
"-1.2.3.4\n"
"1.1.1.1.\n"
"3...3\n\n"
"toto.fr\n"
"truc-bidule.com\n"
"sub.truc-bidule.toto.com\n\n"
"toto\n"
"toto.f\n"
"toto.f6\n"
"-3.fr\n"
"toto.fr \n"
"truc_bidule.com\n"
"sub..truc-bidule.toto.com\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.