re = /^((?=[0-9.]+$)((25[0-5]|(2[0-4]|1[0-9])[0-9]|[1-9]?[0-9])\.){3}(25[0-5]|(2[0-4]|1[0-9])[0-9]|[1-9]?[0-9])|(?=[0-9.]*[a-zA-Z])([a-zA-Z0-9]|[a-zA-Z0-9][a-zA-Z0-9-]{0,61}[a-zA-Z0-9])((\.([a-zA-Z0-9]|[a-zA-Z0-9][a-zA-Z0-9-]{0,61}[a-zA-Z0-9]))*(\.[a-zA-Z]{2,31}))+)$/m
str = '127.0.0.1
192.168.1.1
192.168.1.255
192.168.255.255
0.0.0.0
127.0.0.1
192.168.1.1a
192.068.1.255
30.168.1.255.1
127.1
192.168.1.256
-1.2.3.4
1.1.1.1.
3...3
toto.fr
truc-bidule.com
sub.truc-bidule.toto.com
toto
toto.f
toto.f6
-3.fr
toto.fr
truc_bidule.com
sub..truc-bidule.toto.com
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end