import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?=[0-9.]+$)((25[0-5]|(2[0-4]|1[0-9])[0-9]|[1-9]?[0-9])\\.){3}(25[0-5]|(2[0-4]|1[0-9])[0-9]|[1-9]?[0-9])|(?=[0-9.]*[a-zA-Z])([a-zA-Z0-9]|[a-zA-Z0-9][a-zA-Z0-9-]{0,61}[a-zA-Z0-9])((\\.([a-zA-Z0-9]|[a-zA-Z0-9][a-zA-Z0-9-]{0,61}[a-zA-Z0-9]))*(\\.[a-zA-Z]{2,31}))+)$";
final String string = "127.0.0.1\n"
+ "192.168.1.1\n"
+ "192.168.1.255\n"
+ "192.168.255.255\n"
+ "0.0.0.0\n\n"
+ " 127.0.0.1\n"
+ "192.168.1.1a\n"
+ "192.068.1.255\n"
+ "30.168.1.255.1\n"
+ "127.1\n"
+ "192.168.1.256\n"
+ "-1.2.3.4\n"
+ "1.1.1.1.\n"
+ "3...3\n\n"
+ "toto.fr\n"
+ "truc-bidule.com\n"
+ "sub.truc-bidule.toto.com\n\n"
+ "toto\n"
+ "toto.f\n"
+ "toto.f6\n"
+ "-3.fr\n"
+ "toto.fr \n"
+ "truc_bidule.com\n"
+ "sub..truc-bidule.toto.com\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}