#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\skeyword\s|\skey\s|\s(?![^[]+]$|[^{]+}$))"
Local $sString = "[] []" & @CRLF & _
"[] keyword []" & @CRLF & _
"[] key []" & @CRLF & _
"" & @CRLF & _
"[] ["can contain spaces"]" & @CRLF & _
"[] keyword ["can contain spaces"]" & @CRLF & _
"[] key ["can contain spaces"]" & @CRLF & _
"" & @CRLF & _
"{} {}" & @CRLF & _
"{} keyword {}" & @CRLF & _
"{} key {}" & @CRLF & _
"" & @CRLF & _
"{} {"can":"contain spaces"}" & @CRLF & _
"{} keyword {"can":"contain spaces"}" & @CRLF & _
"{} key {"can":"contain spaces"}" & @CRLF & _
"" & @CRLF & _
"string string" & @CRLF & _
"string string@"$£$£~" & @CRLF & _
"string keyword string" & @CRLF & _
"string key string" & @CRLF & _
"{} {"can": []}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")