import re
regex = re.compile(r"(\skeyword\s|\skey\s|\s(?![^[]+]$|[^{]+}$))", flags=re.MULTILINE)
test_str = ("[] []\n"
"[] keyword []\n"
"[] key []\n\n"
"[] [\"can contain spaces\"]\n"
"[] keyword [\"can contain spaces\"]\n"
"[] key [\"can contain spaces\"]\n\n"
"{} {}\n"
"{} keyword {}\n"
"{} key {}\n\n"
"{} {\"can\":\"contain spaces\"}\n"
"{} keyword {\"can\":\"contain spaces\"}\n"
"{} key {\"can\":\"contain spaces\"}\n\n"
"string string\n"
"string string@\"$£$£~\n"
"string keyword string\n"
"string key string\n"
"{} {\"can\": []}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")