$re = '/(\skeyword\s|\skey\s|\s(?![^[]+]$|[^{]+}$))/m';
$str = '[] []
[] keyword []
[] key []
[] ["can contain spaces"]
[] keyword ["can contain spaces"]
[] key ["can contain spaces"]
{} {}
{} keyword {}
{} key {}
{} {"can":"contain spaces"}
{} keyword {"can":"contain spaces"}
{} key {"can":"contain spaces"}
string string
string string@"$£$£~
string keyword string
string key string
{} {"can": []}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);