import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\skeyword\\s|\\skey\\s|\\s(?![^[]+]$|[^\\{]+\\}$))";
final String string = "[] []\n"
+ "[] keyword []\n"
+ "[] key []\n\n"
+ "[] [\"can contain spaces\"]\n"
+ "[] keyword [\"can contain spaces\"]\n"
+ "[] key [\"can contain spaces\"]\n\n"
+ "{} {}\n"
+ "{} keyword {}\n"
+ "{} key {}\n\n"
+ "{} {\"can\":\"contain spaces\"}\n"
+ "{} keyword {\"can\":\"contain spaces\"}\n"
+ "{} key {\"can\":\"contain spaces\"}\n\n"
+ "string string\n"
+ "string string@\"$£$£~\n"
+ "string keyword string\n"
+ "string key string\n"
+ "{} {\"can\": []}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}