import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(https?|git)[:+]|(.)[:\\/]";
final String string = "npm/npm\n"
+ "gist:11081aaa281\n"
+ "bitbucket:example/repo\n"
+ "gitlab:another/repo\n"
+ "git://github.com/user/project.git#commit-ish\n"
+ "git+ssh://user@hostname:project.git#commit-ish\n"
+ "git+ssh://user@hostname/project.git#commit-ish\n"
+ "git+http://user@hostname/project/blah.git#commit-ish\n"
+ "git+https://user@hostname/project/blah.git#commit-ish";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}