import re
regex = re.compile(r"^(https?|git)[:+]|(.)[:\/]")
test_str = ("npm/npm\n"
"gist:11081aaa281\n"
"bitbucket:example/repo\n"
"gitlab:another/repo\n"
"git://github.com/user/project.git#commit-ish\n"
"git+ssh://user@hostname:project.git#commit-ish\n"
"git+ssh://user@hostname/project.git#commit-ish\n"
"git+http://user@hostname/project/blah.git#commit-ish\n"
"git+https://user@hostname/project/blah.git#commit-ish")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")