$re = '/^(https?|git)[:+]|(.)[:\/]/';
$str = 'npm/npm
gist:11081aaa281
bitbucket:example/repo
gitlab:another/repo
git://github.com/user/project.git#commit-ish
git+ssh://user@hostname:project.git#commit-ish
git+ssh://user@hostname/project.git#commit-ish
git+http://user@hostname/project/blah.git#commit-ish
git+https://user@hostname/project/blah.git#commit-ish';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);