re = /^(https?|git)[:+]|(.)[:\/]/
str = 'npm/npm
gist:11081aaa281
bitbucket:example/repo
gitlab:another/repo
git://github.com/user/project.git#commit-ish
git+ssh://user@hostname:project.git#commit-ish
git+ssh://user@hostname/project.git#commit-ish
git+http://user@hostname/project/blah.git#commit-ish
git+https://user@hostname/project/blah.git#commit-ish'
# Print the match result
str.match(re) do |match|
puts match.to_s
end