const regex = /^(https?|git)[:+]|(.)[:\/]/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(https?|git)[:+]|(.)[:\\\/]', '')
const str = `npm/npm
gist:11081aaa281
bitbucket:example/repo
gitlab:another/repo
git://github.com/user/project.git#commit-ish
git+ssh://user@hostname:project.git#commit-ish
git+ssh://user@hostname/project.git#commit-ish
git+http://user@hostname/project/blah.git#commit-ish
git+https://user@hostname/project/blah.git#commit-ish`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}