#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(123|111)(?:_input|_output)?$"
Local $sString = "New folder" & @CRLF & _
"111_input" & @CRLF & _
"123" & @CRLF & _
"123_input" & @CRLF & _
"456_output" & @CRLF & _
"monitor - Copy - Copy"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")